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Characterizing qPCR Assays Using Different Software Tools. 

Created June 2024, by  

Jonathan Phillips and Gregor Blaha,  

Department of Biochemistry, University of California, Riverside. 

This protocol aims to assist those new to qPCR data analysis and those who seek to escape the closed-

source, proprietary software tied to their qPCR instrumentation.  

Here we describe how to assess the quality of qPCR data and qPCR assays using:  

- CFX Maestro 2.3, the software native to Bio-Rad qPCR instruments,  

- Microsoft Excel version 2404,  

- a Bayesian inference Using Gibbs Sampling (BUGS) script presented by PJ Schmidt et al.,  

- the 'LOD calculator' R-script, and  

- the ‘qpcR’ R software package 

We chose these tools for their blend of familiarity, accessibility, and flexibility. CFX Maestro, is Bio-Rad’s 

software for their CFX instrumentation, but the key steps will be similar across the closed-source, 

proprietary software of other manufacturers. Excel is part of the standard Microsoft Office suite on, 

widely available on Windows. BUGS and R are open-source: BUGS is developed the MRC Biostatics Unit, 

while R benefits from a dynamic community, ensuring continuous innovation and abundant 

documentation.  

The step-by-step instructions of our individual instructions are designed to help you overcome initial 

hurdles and hopefully provide a starting point for deeper exploration and development of your own 

data analysis skills. We are aware that software interfaces will evolve over time, the workflows and 

analytical principles outlined here will remain the same. Even if minor details in our step-by-step 

instructions differ from your version, we hope that these differences can be sorted out with the help of 

AI copilots.  

Because we tried to provide helpful instructions, it caused the current SOP to swell in volume. Other 

sources may be consulted; however, readers may run the risk of spending extraordinary time figuring 

out mundane tasks as has happened to us on many instances.  
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Initial assessment of data quality. 

For the initial assessment of your data, inspect the amplification curve of each reaction using an external 

PC or device. The software to view the amplification curves is typically provided by the manufacturer of 

your qPCR instrumentation.  

The following instructions are for the Bio-Rad CFX Maestro 2.3 software, but similar steps should apply 

to software from other qPCR manufacturers.  

Transferring Data. 

If your qPCR machine is not connected to a network, then use a flash drive to transfer your data. Your 

data files will be formatted in a format specific to the closed ecosystem of your qPCR instrumentation. 

For Bio-Rad instruments, data are stored in the ‘pcrd’ format, identifiable by the ‘.pcrd’ extension at the 

end of your data files (e.g., ‘my_experiment.pcrd’1).  

While a flash drive can serve as a temporary backup, we recommend a more secure long-term backup 

system. Consider investing in an external hard drive or for non-sensitive data a cloud drive, such as 

Google Drive, Apple iCloud, or Dropbox. 

 

Figure 1. The screenshot of the first three steps to load ‘.pcrd’ data into Bio-Rad CFX Maestro software.  

Initial Assessment. 

For the initial assessment, inspect the amplification curve of each reaction.  

 
1 File extensions may be hidden. To show file extensions in Windows ‘File explorer’, navigate in ‘File explorer’ to 
the ‘View’ tab, then to the ‘Show/hide‘ panel, and check the box next to ‘File name extension.’ (See screenshot in 
this footnote.)  
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To view data in Bio-Rad CFX Maestro 2.3, navigate to File > Open > Data File2. (See Figure 1 for 

screenshot displaying the ‘File > Open > Data File’ notation in action.) 

Within the ‘File explorer’ window that appears, navigate to the folder containing your data files and 

select the file you need. Confirm your selection with ‘Open.’  

A ‘Data Analysis’ window with four panels will appear. The upper left panel displays the amplification 

curves of all experiments in your data file. You can toggle individual curves on and off by clicking on the 

colored boxes in the setup panel below the curve display panel. The setup panel mirrors the layout of 

the qPCR plate, with gray boxes representing empty wells.  

 

A normal amplification curve is characterized by four distinct phases: i) Baseline region (aka lagging 

phase3) in which the target DNA is accumulating but is not yet detectable. ii) Exponential phase: The 

signal for the target DNA rapidly rises as sufficient molecules accumulate. iii) Log linear phase: The 

 
2 The ‘>’ symbol indicates the order in which actions have to be taken within a menu. For example, ‘File > Open > 
Data File’ means, to first click on the ‘File’ tab in the menu bar, then select ‘Open’ from the File menu, before 
choosing ‘Data File’ from the Open submenu.  
3 "Lagging phase" is preferred over "lag phase" to emphasize the ongoing DNA accumulation. 
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growth rate of the signal remains constant for a few cycles. iv) Plateau phase: Growth slows down and 

eventually reaches a plateau as resources for amplification dwindle.  

 

Curves that do not display these phases should be further investigated. Table 1 lists common deviations 

with potential causes and remedies.  

In the initial few cycles (~2-4 cycles), the amplification curve may drift. For background subtraction, only 

the stable region of the lag-phase should be used. Fluctuations within the lag-phase across all 

amplification curves are used to automatically determine the threshold for Ct determination. The 

crossing point at which an amplification curve crosses the threshold is the Ct value of the curve.  

The threshold used for Ct determination, represented as straight, horizontal line within the curve display 

panel can be manually adjusted, by dragging up and down. Changing the threshold level will result in 

corresponding changes of the Ct values of all amplification curves. The Ct values of each curve are 

shown under the header ‘Cq’ in the table displayed in the lower right corner of the Data Analysis 

window. 

When the amplification curves are displayed on a semi-logarithmic graph, their log-linear phases should 

be straight lines and parallel each other. Non-parallel log-linear phases result in inaccurate 

quantification. If only a single amplification curve is non-parallel, then exclude it from further analysis. 

Otherwise, consider a different procedure of sample preparation, such as a different DNA extraction 

method. To activate the log scale representation, click on the "log view" box in the right lower corner of 

the curve display panel. 

To ensure reliable quantification, technical replicates should have consistent characteristics. Ideally their 

Ct values should fall within 0.5 cycles of each other. However, the variability inherently increases as the 

Ct values exceed 30 cycles, potentially compromising the reliability of the quantification results.  

To facilitate meaningful comparisons between assays, the Ct values of the positive controls (or dilutions 

of the standard curve) should be within one cycle of the Ct values obtained in previous experiments.  
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In qPCR assays that use intercalating dyes for detection, the formation of primer dimer products can 

lead to high Ct values of the non-template control. Melt curve analysis is essential to verify the presence 

of such dimer products in the NTC. Regardless of the detection method used, the Ct values of the NTC 

should be at least five cycles larger than that of any positive control to ensure the validity of the 

experimental results. 

Amplification efficiency 

A close to 100% amplification efficiency is the hallmark of a high-quality qPCR assay. To determine the 

efficiency, a calibration curve of Ct values against the log concentration is constructed. Typically, 6-7 

concentrations that spanning 6-7 orders of magnitudes are used, with at least 3-4 replicates [Svec D et 

al. 2015]. The efficiency (𝐸) is then derived from the slope of the linear regression of the plotted values 

(Eq. 1).  

𝐸 = 10(−1 𝑠𝑙𝑜𝑝𝑒⁄ ) − 1. 

Theoretically a slope of -3.32 corresponds to an efficiency of 100%. Slopes steeper than -3.32 (e.g., -3.5) 

imply lower efficiency. Conversely, slopes shallower than -3.32 (e.g., -3.2) suggesting an apparent 

efficiency of greater than 100%, which is impossible. The main reason for this apparent contradiction is 

the presence of inhibitors4.  

 
4 In a 10-fold dilution series, the Ct difference between two consecutive dilutions should be around 3.3 for 100% 

amplification efficiency. If inhibitors are present in the sample, this difference may be smaller. As the sample is 

Table 1: Common abnormalities with potential causes and remedies. 

Problem Possible reason Possible solution 
Lagging phase 
longer than 
expected.  

Inefficient primers, suboptimal 
reaction conditions, presence of 
inhibitors, or low starting target 
concentration 

Reorder primers, increase starting target 
concentration, test different cycling conditions, 
replace polymerase mix, and analyze nucleic 
acid sample for inhibitors. 

Lagging phase has 
high fluorescence 

Excessive background noise or 
erratic signals. 

Adjust baseline subtract manually. 

Amplification curve 
dips under baseline. 

Baseline setting is incorrect. Examine raw data. Reset baseline and allow for 
linear change of baseline with cycle number. 

Shallow plateau or 
early saturation 

Insufficient starting target 
concentration or inefficient 
amplification 

Increase starting concentration of target, test 
different cycling conditions and polymerase 
mix. 

Replicates show 
high variability. 

Poor assay efficiency or poor 
pipetting. 

Redesign assay and review SOP on pipetting. 

No increase in 
fluorescence. 

Probe does not bind target 
effectively.  

Optimize Mg2+ concentration. Design the 
primers to produce a PCR product no longer 
than 120. 

PCR-efficiency is 
more than 110% 

Variance of Ct of most 
concentrated or of most diluted 
samples are too large; presence of 
inhibitor; pipetting errors; and 
formation of unspecific products or 
primer dimers 

Exclude most concentrated or diluted samples 
from calculation of efficiency. Change DNA 
purification protocol to achieve a ratio of 260 
to 280 nm absorbance of above 1.8. Check 
calibration of pipettes. Optimize qPCR 
reaction. 
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While knowing the absolute concentration of the analyte is not necessary, the relative concentrations 

between standards are crucial. The relative concentrations are established by the dilution factor used 

for the preparation of the serial dilution of the target. The concentration range chosen to determine 

amplification efficiency should encompass the anticipated experimental range, preferably exceeding it 

by at least 20%. This is due to the inherent compromise in predictive precision at the extreme 

concentrations of a standard curve.  

The stock of target amplicon used to prepare the concentration series should be relevant to the purpose 

of the qPCR. If the purpose is to determine the amplification efficiency of the qPCR assay by itself, then 

the solution should be free of interfering components. However, if the qPCR assay is used for field 

samples, then the solution should include potential inhibitor and interfering substances. This will 

generate a standard curve that realistically mirrors the impact of these inhibitors on PCR efficiency, 

leading to more accurate and meaningful quantification of target molecules in actual field samples.  

Determining Amplification Efficiency in CFX Maestro 2.3. 

Before determining the amplification efficiency, transfer the collected data to an external device, load 

into CFX Maestro and inspected the shape of each amplification curve. (See also Initial Assessment 

above). 

In the ‘Data Analysis’ window, select ‘Plate Setup’ > ‘View/Edit Plate …’. 

 

Select in ‘Plate Editor’ window all wells of the technical replicate of one concentration of the dilution 

series. Select under ‘Sample Type’ ‘Standard’. 

 
diluted, so are the inhibitor and with it their effect on the DNA amplification. Thus, the Ct difference between 

consecutive dilution rise back to 3.3.  
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Scroll to ‘Replicate #’ panel, name the standard and click on box next to load. Enter concentration of 

sample and confirm by hitting ‘Enter’ on keyboard. The selected wells change their headings from ‘Unk’ 

to Std-‘name’ and the entered concentration appears beneath the header. (In figure below the name of 

the sample was ‘1’ therefore the header of wells changed to Std-1.)  

 

Select the technical replicates of the next concentration of the concentration series. Fill out the name 

and concentration. Repeat this for all samples of the concentration series.  

Once all samples of the concentration series are identified and labelled, select ‘OK’ at lower right corner 

of the ‘Plate Editor’ window. The ‘Plate Editor’ closes and the standard curve appears the upper right 

corner of the ‘Data Analysis’. The efficiency of the reaction, R2 value, slope, and y intercept are shown 

below the standard curve. 
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Verify that the slope lies between −3.2 and −3.5 and that the R2 value is above 0.98. To obtain the error 

bar and confidence interval for the slope (and by extension for the amplification efficiency (𝐸)) 

additional software such as Excel, R, or BUGS is needed.  

Determining the Amplification Efficiency and Confidence Intervals in Excel. 

Excel, an integral part of the Microsoft Office suite found on most PCs, is familiar and readily available to 

many users. This section will show how to use Excel to determine the amplification efficiency of qPCR 

assay with a 95% confidence interval.  

To import qPCR data into Excel, they have to be converted into a file format that Excel can read excel, 

such as comma separated values or Excel Open XML Spreadsheet, i.e., ‘csv’5 or ‘xlsx’. First, load the data 

into CFX Maestro 2.3, by navigating to File > Open > Data File. Then export the data as xlsx or csv file by 

selecting ‘Export’ > ‘export all data sheets’ > ‘.xlsx or .csv.’  

Using Windows File explorer, navigate to the folder in which the exported data are and select ‘[file 

name] - Quantification Cq Results.csv.’ Right-click on the file and choose ‘Open with’ > ‘Excel.’  

 
5 csv (comma-separated values) files store data as plain text, with entries separated by commas. Because of this 

simple structure, a wide variety programs can read csv files. 
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In Excel, arrange all the entries of the concentration series of the calibration curve into one table. (In the 

figure below the wells which did not contain the samples of the concentration series were deleted.) In 

the column label ‘Log Starting Quantities’ enter the log of dilution factor or concentration.  

Select ‘Data’ > ‘Data analysis’6.  

In ‘Data Analysis’ window scroll down and select ‘Regression’ and confirm with ‘OK.’ 

Enter ‘Input Y range:’ the cells that contain the Ct values. (In figure below it is the cells H2 to H28.)  

 

Enter ‘Input X range:’ the cells with log of dilution factor or concentration. 

Conf level: defaults to 95% 

Enter the ‘Output Range’ under ‘Output options’ panel. 

Click ‘OK’ on upper right. 

The Summary Output of the Regression analysis is printed into the same spreadsheet. 

 

Confirm that the 95% confidence interval includes -3.32 and that R2 for the fitted line is more than 0.98. 

(In the above shown summary output the 95% confidence interval is -3.342 to -3.116 and includes -3.32. 

 
6 If the ‘data analysis’ toolpak is not installed, then select File > Options. In the Option window, select the ‘Add-Ins’ 
option. In the ‘Add-Ins’ register card select ‘Analysis ToolPak’ and click ‘OK’  
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R2 is with 0.9956 larger than 0.98.) the slope lies between −3.2 and −3.5 and that the R2 value is above 

0.98, as described for standard curve analysis. 

Similar to the regression function in Excel, the lm function built into R and the calib function of the 

‘qpcR’ R-package use linear regression to fit a straight line to the qPCR data. The primary difference is 

that the calib function estimates the confidence intervals using bootstrapping.  

Regardless of which regression function is used, all disregard samples that do not produce a signal (i.e., 

no Ct value). For linear regression to be valid, linear relationship between Ct value and log concentration 

must hold, and the error in Ct value must be constant across all target concentrations. However, these 

assumptions are not valid for qPCR calibration curves. At least one molecule of target must be present 

for amplification, which set limits the maximum Ct value to 35-45 cycles. Additionally, the error in Ct 

values increases non-linearly as the number of target molecules in a qPCR approaches one.  

Determining the Amplification Efficiency and Confidence Intervals with BUGS. 

Schmidt et al. developed a statistical model that accounts for reactions without a signal and for the 

increase in Ct value error. Both effects were attributed to sampling variability of stock solutions with low 

average target molecules. They did not include the effect of imperfect amplification efficiency on the 

spread of the Ct value, deemed it negligible. Implemented in a BUGS script, their model estimates the 

efficiency and spread of Ct values in calibration curves, providing confidence intervals for these 

estimates and their correlation. 

Here we show how to install BUGS, how to prepare the data file and how run the Schmidt et al.’s BUGS 

script. 

To access the most current version of BUGS consult the mrc-bsu.cam.ac.uk/software webpage. At the 

writing of this SOP the most current version of BUGS that works with Schmidt’s et al.’s script is 

OpenBUGS and is available through google drive 

(https://drive.google.com/drive/folders/1XzG681AaZpRtPtynkuGUt2BspMTvhYoP). 

 

Download OpenBUGS323setup.zip onto your computer.  

Unpack the setup.zip file and double click on OpenBUGS323setup.exe file to start the installation.  
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Upon completion of the installation, OpenBUGS can be found under 

the start button in the program/app listing or on the desktop as a 

short-cut on the desktop. 

Double-clicking on the icon. 

To create a new file press ‘Ctrl’ + ‘N’. 

Copy and paste Schmidt et al.’s script.  

Select the text: 

### BEGINNING OF SCRIPT 
 
### PARAMETER DEFINITIONS - Standard curve analysis 
logNq: logarithm of number of amplicons determining Cq - STOCHASTIC VARIABLE 
Nq: signal strength determining Cq - DETERMINISTIC VARIABLE OF INTEREST 
E: PCR efficiency - STOCHASTIC VARIABLE OF INTEREST 
log2sigma: base-2 log of residual Cq standard deviation – STOCHASTIC VARIABLE 
sigma: minimal standard deviation of normal error in Cq about expected value -DETERMINISTIC VARIABLE OF INTEREST 
intercept: intercept of log-linear model - DETERMINISTIC 
slope: slope of log-linear model - DETERMINISTIC 
Y[i]: #gc in well i subjected to PCR - STOCHASTIC NUISANCE VARIABLE 
lambda[i]: expected #gc in well i - CONTROL VARIABLE 
ND[i]: indicator variable for non-detect in well i - MEASURED VARIABLE 
mu[i]: mean of Cq distribution for well i - DETERMINISTIC 
tau[i]: inverse variance of error in Cq - DETERMINISTIC 
Cq[i]: Cq value of well i - MEASURED STOCHASTIC VARIABLE (non-detect Cq = -1) 
 
model { 
  ### Standard curves analysis 
  # Define priors 
  logNq ~ dunif(0, 20)  # 2^40 is approximately 1E14 
  Nq <- pow(10, logNq) 
  E ~ dunif(0, 2.0)    # Coerces PCR efficiency <1 
  log2sigma ~ dunif(-5,3)  # sigma < 2 Cq 
  sigma <- pow(2, log2sigma) 
  intercept <- log(Nq) / log(1 + E) 
  slope <- -log(10) / log(1 + E) 
  # Define likelihood 
  for (i in 1:m) { 
    # Work-around to coerce Y=0 for non-detects and Y>0 otherwise 
    Y_branch[i, 1] ~ dpois(lambda[i]) T(1,) 
    Y_branch[i, 2] ~ dpois(lambda[i]) T(0, 0) 
    Y[i] <- Y_branch[i, ND[i] + 1] 
    # Work-around to avoid log(0) error when Y=0 
    mu_branch[i, 1] <- (log(Nq) - log(Y[i])) / log(1 + E) 
    mu_branch[i, 2] <- -1   # Assign impossible Cq when Y=0 
    mu[i] <- mu_branch[i, ND[i] + 1] 
    # Work-around to dissociate non-detects from estimation of tau 
    tau_branch[i, 1] <- pow(sigma, -2) 
    tau_branch[i, 2] <- 1000000 
    tau[i] <- tau_branch[i, ND[i] + 1] 
    Cq[i] ~ dnorm(mu[i], tau[i]) # Small impossible Cq for non-detects 
  } 
} 
## END OF SCRIPT 

 
Press ‘Ctrl’ + ’C’. Go to the open text window in OpenBugs, and press ‘Ctr’ + ’V’. 

Save the text file with ‘Ctrl’ + ‘S’ and entering filename. We prefer to save the file as ‘Model.txt’. 

To feed the model to the OpenBUGS, press ‘Alt’+’M’ and ‘Alt’ + ’S’.  
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In the ‘Specification Tool’ window, click on ‘check model.’  

In case the warning “the new model will replace the old one” shows up, 

select “ok” 

In the lower left corner of program interfac BUGS should report ‘model 

is syntactically correct.’ 

Next create a new file for the data. Press ‘Ctrl’ + ‘N’ and copy and paste 

data below. 

Select the text: 

### BEGINNING OF DATA  
##-Simulated data for figure 5 in Schmidt PJ et al. Frontiers in Microbiology. 
list(m = 101,  
lambda = c( 0.01, 0.011220185, 0.012589254, 0.014125375, 0.015848932, 0.017782794,  
      0.019952623, 0.022387211, 0.025118864, 0.028183829, 0.031622777,  
      0.035481339, 0.039810717, 0.044668359, 0.050118723, 0.056234133,  
      0.063095734, 0.070794578, 0.079432823, 0.089125094, 0.1, 
      0.112201845, 0.125892541, 0.141253754, 0.158489319, 0.177827941,  
      0.199526231, 0.223872114, 0.251188643, 0.281838293, 0.316227766, 
      0.354813389, 0.398107171, 0.446683592, 0.501187234, 0.562341325,  
      0.630957344, 0.707945784, 0.794328235, 0.891250938, 1, 
      1.122018454, 1.258925412, 1.412537545, 1.584893192, 1.77827941, 
      1.995262315, 2.238721139, 2.511886432, 2.818382931, 3.16227766,  
      3.548133892, 3.981071706, 4.466835922, 5.011872336, 5.623413252, 
      6.309573445, 7.079457844, 7.943282347, 8.912509381, 10, 
      11.22018454, 12.58925412, 14.12537545, 15.84893192, 17.7827941, 
      19.95262315, 22.38721139, 25.11886432, 28.18382931, 31.6227766, 
      35.48133892, 39.81071706, 44.66835922, 50.11872336, 56.23413252, 
      63.09573445, 70.79457844, 79.43282347, 89.12509381, 100, 
      112.2018454, 125.8925412, 141.2537545, 158.4893192, 177.827941, 
      199.5262315, 223.8721139, 251.1886432, 281.8382931, 316.227766, 
      354.8133892, 398.1071706, 446.6835922, 501.1872336, 562.3413252, 
      630.9573445, 707.9457844, 794.3282347, 891.2509381, 1000), 
 
Cq = c( -1, -1, -1, -1, -1, -1,  
             -1, -1, -1, -1, -1, 
            -1, -1, -1, -1, -1, 
            -1, -1, -1, -1, -1, 
            -1, -1, 35.8602, -1, 35.8092, 
            -1, -1, -1, -1, -1, 
            -1, 35.5049, -1, 35.8219, 35.1534, 
            35.9755, 35.563,-1,-1,35.0651, 
            35.534, 36.3365, 35.8594, 36.774, 34.2842, 
            33.8225, 35.2291, 33.1403, 35.5969, 35.3019, 
            -1, 33.5692, 33.2265, 34.8736, 33.12, 
            33.017, 32.3309, 33.8445, 32.001, 32.758, 
            32.4932, 33.1047, 31.3781, 31.5947, 31.0426, 
            30.9078, 31.0592, 31.3859, 30.8578, 31.0623, 
            29.8194, 29.709, 30.4137, 29.5989, 29.7712, 
            29.7926, 29.5147, 29.5546, 29.0695, 29.0791, 
            29.1218, 28.4307, 28.5021, 28.084, 28.0578, 
            28.0512, 27.4491, 27.5105, 27.383, 27.5636, 
            26.9562, 26.5394, 26.4061, 26.2641, 25.7979, 
            26.418, 25.5072, 25.8598, 25.3087, 25.5423), 
 
ND = c(1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 
1, 1, 1, 1, 1, 1, 1, 1, 1, 1, 
1, 1, 0, 1, 0, 1, 1, 1, 1, 1, 
1, 0, 1, 0, 0, 0, 0, 1, 1, 0, 
0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 
1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 
0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 
0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 
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0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 
0, 0, 0, 0, 0, 0, 0, 0, 0, 0) 
)  
## END of DATA 

 

Press ‘Ctrl’ + ’C’. Go to the open text window in OpenBugs, and press ‘Ctr’ + ’V’. 

Save the text file with ‘Ctrl’ + ‘S’ and entering filename. We prefer to save the file as ‘Data.txt’. 

In the ‘Specification Tool’ window, click on ‘load data.’  

In the lower left corner of OpenBUGS interface ‘data loaded’ should be stated. 

Set the number of chains to 3 and click on ‘compile.’ ‘model compiled’  

In the lower left corner of OpenBUGS interface ‘model compiled’ should be stated. 

To initiate the simulation click on ‘gen inits’ 

In the lower left corner of OpenBUGS interface ‘initial values generated, model initialized’ should be 

stated. 

Open ‘Sample Monitor Tool’ window by pressing ‘Alt’ 

+ ‘N’ and ‘Alt’ + ‘S.’ 

Enter in ‘node’ text box: intercept. Click on ‘Set.’ 

Enter in ‘node’ text box: sigma. Click on ‘Set.’ 

Enter in ‘node’ text box: E. Click on ‘Set.’ 

Enter in ‘node’ text box: *. 

Set value of ‘beg’ text box to 1000. 

Check that in the percentiles 2.5, median, and 97.5 are selected.  

To start the simulation, press ‘Alt’ + ‘M’ followed by ‘Alt’ + ‘U’ 

Note: ‘Specification Tool’ window may cover the ‘Update Tool’ 

window. Move the ‘Specification Tool’ window to side.  

In ‘Update Tool’ window set the ‘updates’ to 10000.  

Click on ‘update’. The number of iterations should steadily increase to 10000. 

In the ‘Sample Monitor Tool’ click on ‘Stat’ to open the ‘Node statistics’ window. 
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To correlation between E and sigma, press ‘Alt’ + ‘N’ followed by 

‘Alt’ + ‘O’. 

In the ‘Correlation Tool’ Window, enter for nodes E and sigma, and 

big 1000. Click on ‘Scatter’ 

 

 

To apply the Schmidt et al’s script on other data, edit in the data file:  

i) the number of molecules in each reaction under lambdba, i.e., lambda = c(  number of 

molecules in each reaction  ).  

ii) the Ct value for each reaction in the order entered in i) under Cq, i.e.,  

Cq= c(  Ct values  ). ND, NaN, and non-detects are enter as -1.  

iii) Provide index for each reaction in the order entered in i) under ND, i.e., ND = c( list of 0 and 

1’s). Reactions with Ct value are indexed 0 and those with ND/NaN/non-detect are indexed 

1. 

Determining the limit of detection and quantification using the R script LoD-calculator. 

Besides amplification efficiency, frequently the limit of detection (LOD) and quantification (LOQ) are 

reported as indictor for the quality of an qPCR assay. Here we show how to determine the LOD and LOQ 

using the LoD-calculator script developed by C.M. Merkes and presented in [Klymus KE et al. 2020]. 
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For the LoD-calculator.R script to work well, a lot of data is needed. The test data set provided by C.M. 

Merkes contains 96 measurements for each of the 6 concentrations of the standard curve (1000, 1000, 

100, 10, 5, 1 starting quantities). The script can be found at 

https://github.com/cmerkes/qPCR_LOD_Calc/blob/master/LoD-calculator.R.  

 

To download the script, click on ( ). 

The script expects a csv file with columns for the well position, fluorophore used, sample name, Cq 

value, starting quantity, and target name with the headings ‘Well’, ‘Fluor’, ‘Sample’, ‘Cq’, and ‘Target’. 

Missing information can be added to the csv files using Excel. 

To open file navigate to your data file with Ct values. Right-click onto the file and select ‘Excel’ under 

‘Open with.’ 

In the spreadsheet, delete all the columns that are not ‘Well’, ‘Fluor’, ‘Sample’, ‘Cq’, and ‘Target’. To 

delete these columns, select the column letter, right-mouse click, and select ‘Delete.’ Delete all the rows 

of wells that are not part of the standard curve. To delete 

these rows, select the number in the first column, right-

mouse click, and select ‘Delete.’ 

Fill in the missing information, i.e., what target was used, 

what sample, and what concentration. Each concentration 

must have a unique sample name. 

Save file as csv file. To save file, use ‘File > Save As’, navigate 

to your data folder, name your file, and save as csv file 

(CSV(MS-DOS)(*.csv)). 

  

https://github.com/cmerkes/qPCR_LOD_Calc/blob/master/LoD-calculator.R
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R and RStudio 

The LoD calculator script was in R. To harness the power of R7, we rely on RStudio. RStudio is a versatile 

integrated development environment (IDE) that provides a consistent and user-friendly experience 

across various operating systems [R Core Team 2023; RStudio Team 2020]. 

When you open RStudio for the first time, you will see four panes: the R Script/Source, the 

Environment/History, Console, and Files/Plots (see below). 

 

 

In RStudio, open the script “LoD-Calculator.R” by navigating under ‘File > Open File …’, to the folder 

containing LoD-Calculator.R. Select the script file and click on ‘Open.’ 

Set your working directory (‘setwd’) as the folder location8 of your prepared csv data file.  

Set the ‘Data.csv’ to the ‘[name of prepared file].csv’.  

 
7 To install R and RStudio, see appendix ‘How to Install R and RStudio.’ 
8 In Windows operation system the file path uses single ‘\’ in the path of a file. For R those have to be changed to 
‘/’. For example, the Windows path ‘C:\Users\Downloads\’ should be changed to ‘C:/Users/Downloads/’ for R. 
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Press ‘Shift’ + ‘Ctrl’ + ‘Enter’ to run the whole script  

 

The standard curve for the target will be displayed in the Files/Plots pane under the Plots tab. 

In the Console pane, press ‘Enter’ to display the ‘LoD plot’ in Files/Plots pane. 
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N replicate LoD referes to the probability of having at least one replicate producing a positive signal 

among n replicates, with each replicate having 0.95 chance of producing a positive signal.  

𝑃𝑜𝑛𝑒 𝑝𝑜𝑠𝑖𝑡𝑖𝑣𝑒 = 1 −  √0.05
𝑛  

In the Console pane, press ‘Enter’ to display the last plot displaying the LoD level as red line and the 

concentration range below the LoQ level as gray bar. In addition, Lastly, three csv files are written into 

your data folder, ‘assay summary.csv’, ‘potential outliers.csv’, and ‘LOD_confint.csv’ 
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Using qpcR package in R to determine quantification cycles (Cq values). 

Due to high noise levels in qPCR data, the threshold used to determine the Ct value may be so high that 

some curves cannot cross it. In such cases, the R-package qpcR can extract Cq values, which are derived 

from the shape of the amplification curves rather than the size of the observed RFU signal. 

Installing ‘qpcR’ 

To install qpcR, type in the R Script/Source pane ‘install.packages(“qpcR”)’ and hit ‘Ctrl’ and ‘Enter’ at 

the same time on keyboard. (Throughout this SOP, we use the ‘R>’ symbol to indicate the prompt in the 

R Script/Source pane, i.e., the start of a new line of code in the R Script/Source pane. To run the line of 

code, move the cursor into the line of code and hit ‘Crtl’ + ‘Enter’ on the keyboard.) 

R> library(qpcR) 

Now you all the functions of the qpcR package are available. (For the complete documentation of all the 

functions available in qpcR [Spiess A.-N. 2022]) 

Preparing the csv data file 

Within Windows ‘File explorer’, navigate to the folder you export your data to and select your file ‘[file 

name] – Quantification Amplification Results_[fluorophore].csv.’ Open file though right mouse and 

selecting in popup window ‘Open with’ > ‘Excel.’  

In the file, the data are arranged in columns. Starting with column 2 the cycle numbers are recorded, 

followed by signal recorded during amplification at each cycle, starting with A1 to the last well of the 

plate. (In the figure below the empty first column and the wells which did not contain samples of the 

concentration series were deleted. To delete these columns, select the column letter, right-mouse click, 

and select ‘Delete.’ Column B is selected in figure.)  

 

To save file, use ‘File > Save As’, navigate to your data folder, name your file, and save as csv file. 
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Reading the .csv data into R and determining Cq-values with qpcR 

First step is to read your data file as a csv file9 into R. In R, the data are store stored as a data frame10, in 

our example called ‘qPCR_data.’ 

R> qPCR_data   <- read.csv("C:/[path to folder you exported your csv data files]11/[file name with 

amplification curves].csv”) 

In the next step, fit a curve through your data, here we use the ‘modlist’ command from the qpcR 

package. For the command to fit the data, the data frame, column for cycle numbers and the column 

with data have to be specified. Furthermore, the kind of curve, which cycles are part of the baseline, and 

how the baseline should be corrected have to be specified. In our example below: The data are in data 

frame ‘qPCR_data’, the cycle number are in column 1, i.e., cyc=1, the amplification curve is stored in 

column 2, ‘fluo=c(2)’, the fitted curve is logistic regression with seven parameters, ‘model=l7’, the cycles 

that form the baseline are cycle 6 through 20, ‘basecyc=6:20’, and the mean value of the baseline value 

is subtracted, ‘baseline="mean”.’ For more keywords and options of each keyword see [Spies, A.-N., 

2022] 

R> qPCR  <- modlist(qPCR_data, cyc=1, fluo=c(2), model=l7, basecyc=6:20, baseline="mean") 

To visualize the fit plot the data and the curve with ‘plot‘: 

R> plot(qPCR, type="all") 

The data are displayed in the File/Plots pane under the Plots tab. 

To determine the quantification cycle as described in Guescini et al (2002), aka Cy0, 

R> Cy0_qPCR   <- sapply(qPCR, function(x) Cy0(x)) 

To display the value: 

R> Cy0_qPCR 

Or the maximum of second derivative of the fitted curve, cpD2, also used as a Cq estimate.  

R> cpd2_qPCR   <- sapply(qPCR, function(x) efficiency(x, plot=FALSE)$cpD2) 

To display the value: 

R> cpd2_qPCR 

  

 
9 In R ‘#’ is an indicator for remarks. Anything following it will be ignored by R. 
10 A data frame is an object used in R to store data in a particular form, a matrix. 
11 In Windows operation system the file path uses single ‘\’ in the path of a file. For R those have to be changed to 
‘/’. For example, the Windows path ‘C:\Users\Downloads\’ should be changed to ‘C:/Users/Downloads/’ for R. 
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Appendix: How to Install R and R-Studio 

Download R from the Comprehensive R Archive Network (CRAN): http://CRAN.R-project.org. 

Select ‘Download R for Windows’, ‘install R for the first time’, and ‘Download R-<version> for 

Windows12’.  

Navigate to ‘Download’ folder on your computer and double-click on ‘R-<version>-run.exe.’13  

Confirm the execution of the of ‘R-<version>-run.exe’ by selecting ‘Run’ in ‘Open File – Security 

Warning.’ 

Follow instructions of ‘Setup – R for Windows <version>’ installer. 

To install R-studio go to the https://posit.co/download/rstudio-desktop/ site. Select ‘Download 

RStudio Desktop for windows.’ 

Navigate to ‘Download’ folder on your computer and double-click on ‘RStudio-<version>.exe.’14  

Confirm the execution of the of ‘RStudio-<version>.exe’ by selecting ‘Yes’ in ‘User Account 

Control’ window. 

Follow instructions of ‘RStudio Setup’ installer. 

 
12 <version> of our R installation from January 2024 was 4.3.2, i.e., ‘Download R-4.3.2 for Windows.’ 
13  Download folder is the default folder for files that are downloaded. However, if you changed the default folder 
or selected a different folder to download files then navigate to that folder. 
14 <version> of our RStudio installation from January 2024 was 2023.12.0-369, i.e., ‘RStudio-2023.12.0-369.exe.’ 

http://cran.r-project.org/

